1. Dismiss Notice
  2. Within our Resources section we have over 150 Audio files, with room to grow. You may find exactly what you have been looking for. Just CLICK HERE to start your listening adventure.
    Dismiss Notice
  3. Why would you want to upload your resources directly to RMMV.co? It makes it easier for other members to download them. Click HERE for more information.
    Dismiss Notice
  4. Click HERE to see our four new featured resources by TheUnproPro, Starbird, iblamevictoria, and VGM MarkH.
    Dismiss Notice
  5. Here are the The Resource Rules.
    Dismiss Notice
  6. Please read these RULES before posting.
    Dismiss Notice

Android RPG Maker MV Guide

Discussion in 'MV Tutorials' started by Xilefian, Apr 28, 2017.

  1. Thanks for ur very quick reply :o. Ur awesome. Im a Noob and I dont knew where I should start searching the bug.
    I tried but it wasn't the internet permission xD. Do you know anything about this Error? You looks very experienced with this things ^^

    I forgot to post the Error on my mobile device:"Cannot read property 'length' of undefined"

    I Wrote to the author, too. Thanks for the help :)

     

    Attached Files:

  2. That's a Javascript error, which indicates a Plugin bug. The author will know how to fix it.
     
  3. First of all thank you for creating a nice project file.
    This article is written in Google Translator and can be awkward.

    As the project is updated to 1.0.5, the behavior of the "back button"
    It has been changed so that it can launch an Android message window that prompts you to respond to "cancel" in the game or to end the game.

    The problem is that while the "back button" usually plays the role of "cancellation" in the game,
    UX, you can not launch a window asking if you want to quit the game when there are no more UI elements to be removed.

    I recently watched a video of an off-line kick-off meeting in connection with the Google Indie Game Festival 2018.
    As we go through the lecture, Google reiterated that the behavior of this "back button" would be advantageous to strictly adhere to Google's developer guidelines, a very important factor in Google's judging.

    However, in the current situation, if the "back button" plays the role of "cancel"
    The "End game" function will be disabled.
    Conversely, if you play the role of "game end"
    "Back button" can not be bound to the "Cancel" button in the game.

    This is a negative factor that obviously does not comply with Google's developer guidelines.
    If you do not follow the developer guidelines, not only the Google Indie Games Festival,
    Since then, it has not been selected as a favorite game of Google Play.

    I hope that all RPG MAKER MV games packaged using this project file will not have any disadvantages in keeping up with the Google Developer Guidelines.

    Is there a way to do this temporarily?
    Or do I have to wait for the next version of this project file to update?
     
  4. #184 PineBox, Dec 14, 2017
    Last edited: Dec 14, 2017
    Incredible work, Xilefian!

    It worked great for me. I was able to build a signed Webview apk that works really well on my phone.

    One question, though. The game app is able to save but unable to load savegames. Could you please advise me on how to solve the problem?

    Regarding this, a 2-finger touch equates to "cancel" or "back", so having the device's back button bound to "game end" is not really a problem.
     
  5. Anytime I run my app I get the splash screen and then have a reference error. "require is not defined"
    Is there any way to figure out where in the code something just says require with no value?
    I am using the auto-updater and custom splash screen plugins. I'll try it with auto-update disabled.
     

    Attached Files:

  6. One of your Plugins is "Desktop Only" - meaning it's not compatible with web browser or mobile platforms. I am guessing it is the "auto-updater" Plugin.

    Ask the Plugin author to add compatibility so it does not crash.
     
  7. Removing the auto-updater plugin fixed it but now I just have a gray screen with the music playing.
     
  8. Are you sure this grey screen is not caused by you removing the auto-updater? It is my understanding that the auto-updater Plugin replaces some of the default Javascript code and downloads additional files that it depends on, perhaps the process of removing it has left it broken.

    I'm blaming the Plugin because no-one else has reported a grey-screen issue and so far 99.999% of issues people have had are due to undiscovered bugs in the Plugins that they are using. Do consider asking the Plugin author for help.
     
  9. I moved it to my actual phone it works perfectly. I guess it was just the android emulator. I'm sorry to spam you with my stupidity.
     
  10. I've spent countless precious time trying to export my project to my android phone. Hurdle after hurdle, I just couldn't get the python/crossrwalk/etc. method detailed in the program help file to work, and other programs to automate the process failed. And if spending five hours on a software puzzle were mind-wracking in the past, it's multiple times so when three small children won't give me an uninterrupted ten minute train of thought!

    This did it. Thank you so much for this!.
     
  11. So, I tried to give this thing a go still, does the android studio store false information into user's appdata or something? Because it keeps asking me to include a file that's literally no longer in the game, that I removed from both the game and the folder as it was causing problems when deploying and still it somehow wants that included because of... reasons? It deployed just fine without it but now it's throwing me a hissy fit about it being missing despite the fact that I copied WWW earlier with it missing just fine.
     
  12. You need to be more descriptive of your problem. Where are you seeing this missing file error?

    EDIT: Tell us what Plugins you are using too. I've said this a million, billion times now: 99.999999% of problems that people have are bugs in Plugins that they are using, so please tell us what Plugins you are using so we can help figure out which one is behaving badly.
     
  13. In img pictures folder, it was just a regular picture used in show picture command.

    I have over 300 plugins.
     
  14. Better start listing them, because if nothing is wrong with your project then the problem is almost certainly with one of the Plugins you're using.

    Some Plugin authors only write their code to work on desktop deployed MV, they don't write the Plugin for compatibility with web deployment or mobile deployment. SumRndmDde is infamous for writing Plugins that only work on desktop deployment - so maybe start by listing any Plugins by this author that you have installed.
     
  15. #195 DeadHgH, Dec 31, 2017
    Last edited: Dec 31, 2017
    It can be because you used crosswalk. If take old phone with old Android (I catched this on 5.0) it could happen.

    Also It can be problem of Rpg Maker core. Why I think so? Because some people catch the same problem on PC.
    So i had the same problem (core version was 1.3.1), on some phones work on some one not (gray screen). I already updated core (now 1.5.1) on project, but don't have any feedback yet.

    I have another problem. It happen when i try create apk. Debug work fine.

    Error:Execution failed for task ':app:packageWebviewRelease'.
    > Execution of compression failed.
     
  16. Support is not given for release builds or anything attempting to target commercial release. You'll have to search on Google about this error or hope someone else here can answer your questions.

    A quick search on Google immediately gives me answers for this problem, so you should be able to solve it without help rather easily.
     
  17. Ok. Thanks. I'll try to solve by myself. And this not a commercial release or something close to it. All my experience end on this forum, so i'll not risk and going in commercial.

    Anyway thanks for answer.
     
  18. Again, this whole image is not referenced anywhere in the entire game. Period. I deleted it specifically since it gave problems when deploying. I used this deployed www folder to Android then deleted it later when I was tring to lower the size but then basically just copied the same deployed www folder again. Then it began to tell me the picture was missing, even though that was not called anywhere in the program nor did even exist any more when deploying.

    Like, this sort of stuff only happens in Android Studio. Clearly there is some sort of a cache or a temp working folder where it stores data for cross referencing. I need to know where this is so I can delete it and make it not try and pretend there's files needed that don't need to exist.

    It did NOT complain to me first time when I just copied WWW folder but second time after copying exact same WWW folder it started to give me errors.
     
  19. Have the same problem. In my case that was rar file, that i forgot in folder. But when I deleted WWW again and copy it on second time, error is disappeared.
     
  20. You can try deleting the build-cache, which is located here: <user-home>/.android/build-cache/ (WARNING THIS COULD BREAK ANDROID STUDIO - CLOSE THE PROGRAM BEFORE DELETING)

    However, Android Studio does not cache the Assets folder - there isn't any reason to cache this folder as it's expected to be raw data so the program doesn't cache it at all and expects the Assets to be modified between builds. I very highly doubt deleting the cache will solve your problem - especially when you're getting missing image errors, which are RPG Maker MV errors, not Android or Android Studio errors (Android Studio does not track the contents of the Assets folder - at all).

    I doubt your device is holding a cache either as 100% of the code related to resource management comes from your RPG Maker MV project, there's nothing that would cause a device to cache code. You can rule this scenario out by uninstalling the game from your Android device then installing the APK again. I'm guessing you've already tried this.

    After ruling out the fact that the zero caching is happening here, the only thing left that could be causing this RPG Maker MV error is something inside the RPG Maker MV project: RPG Maker MV errors are always due to project or Plugin bugs. These are the 99.999% of errors people get. Make sure your project is not WebGL only (test it in canvas graphics mode, the community basics Plugin can do this), make sure your project is not Windows-only (file names must be correct casing - try your project on Mac or Linux to test this) and make sure your project is not desktop-only (test it on Web). Testing on Android also proves that it is not desktop-only, and from what you're saying this test is failing.

    Because this is not a WebGL exception, the blame isn't WebGL support on your device.

    Process of elimination is that a Plugin is misbehaving. The fact that you refuse to tell us what Plugins you are using makes me even more convinced that this is the case (combined with the fact that 99.999% of everyone else's errors have been Plugin related so far). You need to tell us what Plugins you are using, otherwise we cannot help you. Help us help you is what I'm asking for.

    Further things to diagnose: When is this error appearing? Does it appear at the title screen when the game loads? Does it appear when a map loads? Does it appear after New Game or Continue? What is the file path of the image in the error? If a regular show picture from a show picture command is causing the title screen to crash then you know for certain that it's a Plugin causing the problem (attempting to pe-load images from some kind of cache or compressed data directory). Show picture will only load a picture when it is used on the map.
     

Share This Page

Loading...