1. Dismiss Notice
  2. Within our Resources section we have over 150 Audio files, with room to grow. You may find exactly what you have been looking for. Just CLICK HERE to start your listening adventure.
    Dismiss Notice
  3. Why would you want to upload your resources directly to RMMV.co? It makes it easier for other members to download them. Click HERE for more information.
    Dismiss Notice
  4. Click HERE to see our four new featured resources by TheUnproPro, Starbird, iblamevictoria, and VGM MarkH.
    Dismiss Notice
  5. Here are the The Resource Rules.
    Dismiss Notice
  6. Please read these RULES before posting.
    Dismiss Notice

Android RPG Maker MV Guide

Discussion in 'MV Tutorials' started by Xilefian, Apr 28, 2017.

  1. I don't think I understand what you're trying to do. Firebase's test system has audio disabled, you won't be able to hear anything at all through Firebase.

    If it doesn't crash, then it's working fine. Audio playback issues are related to device and formats supported. Here's all the audio formats that Android supports; https://developer.android.com/guide/topics/media/media-formats.html

    If the crash looks like this; http://imgur.com/a/yyS2r then it's a Javascript problem in your project or in RPG Maker MV itself.

    If you get an actual crash, then please run a default RPG Maker MV project to see if that crashes. If the default RPG Maker MV project doesn't crash, then you need to change your audio formats to one that is supported by Android (see above).

    If you get a real crash with a default RPG Maker MV project, then send me the crash logs and I'll investigate. Firebase gives you crash logs. To save you some time; I've tested it already with Firebase with a default RPG Maker MV project and it all works perfectly fine for every device Firebase has (yes, every single device available - both WebView and Crosswalk).
  2. Simply Incredible! You've done a wonderful job with this. (hella)(thumbsup)

    This guide has helped me very much in my development. (glad)
    Now I have a more simplistic code design and I'm not stuck with Cordova anymore. (wink)

    Thank you for all your efforts! (jolly)

    Seriously I cannot even tell you enough how much I appreciate this guide. (icecream)(icecream)(icecream)
  3. I want to ask, does your project have plugins or is it very simple with basic plugins.
  4. #84 CT_Bolt, Aug 4, 2017
    Last edited: Aug 8, 2017
    My project uses over 50 plugins & most of my project consists of java & JavaScript that I've wrote special just for my game. (cool)
  5. I have two more small updates on the graphics issue:

    1. A friend of mine, who is testing the game on a Samsung Galaxy S7, is NOT having the graphics issue.
    2. I loaded up an MV web-deployed game on my Galaxy S6 that I found earlier on itch.io; while the graphics were really hard to see, I didn't notice any fuzzing or weird lines.

    Well, I think I've about exhausted my Google-fu abilities in relation to this issue. I did notice that, in terms of graphics issues with android game development and Samsung devices, that some other games and engines have had issues with textures and "mipmapping" as well. Oh well, fortunately it's not a game-breaking issue.
  6. First of all thank you very much for your guide.

    I had excellent results with audio when using crosswalk 17.46.448.10 with intel XDK
    How can I use this specific version to compile my project ?
    If you want to test it, I can link you to my game on the google play store.
  7. #88 firecat, Aug 9, 2017
    Last edited: Aug 9, 2017
    Good news, i got it to work and found the problems that are causing it. the file names weren't updated in the database so i had to looked and renamed it to the files. This was from the post who say to rename the files without special characters but this made me forget about editing it on the rpgmaker editor.

    After that i try to test it on emulators like koplayer and Nox, only Nox was able to play it. a few test shows ram is the main cause to the apps crashing and lagging, don't know if it is my app only or rpg maker that requires high ram usage, i'll keep testing to find out. it matches with firebase phone rams too were the ones who crash were the lower ram usage.

    Music doesn't play but hey, everything else works including sfx, i'll fix this once i find out why. save button is broken so i have to let everyone know that it is broken.

    overall, its great, almost to lunch relase.

    Edit: Music fix the online websites didn't make the frequency to fit the m4a file which causes the program to run the file but inaccourty get the information to produce the sound. now i'm releasing it on google play.
  8. Go ahead, but please link back to this thread and state that it is a translation of this guide by Xilefian. You can re-host the project download, but keep in mind that I do update it so your guide may become out of date after I update the project.
  9. dont kill me if i just leave to do something easy but...
    i try to do what are there, put the files in their place
    the first time my game start to show errors "not found file \se\whatever.m4a (because he are .ogg) and the screen flashes with the error (in the menu and ingame)
    ok, then i discover: its just don't encript
    trying again my game flashes and become all black ¬¬
    if i minimize and go back he stop flashing for 3 seconds
    looks like the battles (found a battle hearing the sounds) are working fine (but with some random noite (?)) and change crosswalk for webview just go worse

    any ideas? (maybe its just something stupid and i cant see...)
    (sorry if i have bad english)
  10. hi so im new to this and i had a error occur when i tried opening the android file gradle it called this error Error:Failed to find Build Tools revision 25.0.3

    i don't suppose i missed something during setup?
  11. Hi,
    Thanks for detail step by step.
    Got this error when sync now.
    Is there anything wrong ?
    How can I fix this ?

    Attached Files:

  12. Did you remember to complete Step 2? This image shows the build tools installation part of Step 2. Make sure Android SDK Build-Tools is selected and installed.

    To re-open this downloader you need to click on Tools → Android → SDK Manager

    You need to be online to be able to synchronise the dependencies. If your computer is already connected to the internet; try clicking the "Disable offline mode and sync project" option presented to you.
  13. Whoaa, That was fast.
    Thank you for fast response.
    I'm on the step 6 now.
    I plugged my phone on usb port on my computer.
    It is detected by my computer.
    But when I debug it, It says no connected devices.
    So I kinda skip it to the Build apk part.
    Building everything now, Hopefully it'll be working.
    --- Double Post Merged, Aug 16, 2017, Original Post Date: Aug 16, 2017 ---
    Edit : I tried to build apk, and it was successfully build.
    When I try to install and run on my phone, there's this message :
    I make sure the pic and music is all in, and there's no problem when i run it on rpg maker.
    Did I do something wrong.

    Note : Sry if I doing some silly mistakes, since it's 5 AM and still not sleep yet and new to rpg maker mv and android manager
    Thank you.

    Attached Files:

  14. Are you using any Plugins? This is not a normal error message and suggests that your phone's web browser is failing with Javascript or this is a bug in RPG Maker MV itself.

    It's far, far more likely to be a Plugin issue if you have any Plugins. HTML Image Elements are not a normal part of RPG Maker MV's runtime, it really does sound like a Plugin issue.
  15. Yes,
    Yanfly picture common event is the problem for my case (luckily i just got 4 plugins on, so i don't mind to check it one by one.)
    But it's alright now, it's working perfectly !

    Thank you so much for this step by step tutorial and really fast response.
    I really do appreciate it
  16. I'm actually wondering what caused that crash with Yanfly's Picture Common Events. I am using that plugin as well and have had no issues in any deployment test. Perhaps you were using a different file type besides PNG? I only wonder in case there might be some phones or browsers that wouldn't support games with this plugin.
  17. Hey guys, new here, but I was following your guide here and there is now build.gradle (module file showing up in android studio. Anyone else experience that? If so how do I fix it?
  18. Hi, Sry for late reply.
    I don't remember well, The only things I did was erase all common event in picture I didn't use, And Then everything works fine. (Which actually should not be the problem)

    The only issue that I had up until now is :
    - I don't know if this work in ios (Which is logically couldn't since it's for Android)
    - When deploy, and copy paste to Assets and build apk, sometimes the music / SE is missing,
    The solution for this problem is : Uncheck encription audio files when you want to deploy, as for me, I put ogg and m4a files before deploy (Just in case)

    - Android 6.1 (Marshmallow) can't install it, I don't know either it doesn't support or need a special installer (It doesn't have any app to open this file)

    Bonus : My experience : When you deploy for website, And test it on google chrome, there'll be error "Can't find file actor.json" or something like that, even there's the file in the folder, Try to use mozilla firefox and everything will be fine.

    Are you sure you already connected to the internet ?
    I do, I try it from the start again and the second try was successful (And make sure you connected to internet from the first step in android studio)
  19. Okay, I started from scratch with the zip download this time to try to get the build.gradle(module) to show up in android studio but now it says there is NOTHING to show upload_2017-8-24_8-5-19.png

    To be honest I have succeeded in packaging the apk through the method provided by rpg maker mv. My only issue, the one that led me to try this method, is that I need to do something about the native android back button closing the game without saving or warning.

Share This Page