Glitched event animations

GO TO ADMIN PANEL > ADD-ONS AND INSTALL ABSTRACT SIDEBAR TO SEE FORUMS AND SIDEBAR

Mr. Open

NPC
Joined
Mar 5, 2017
Messages
20
Points
17
Age
21
I downloaded an animated boat and I was planning to use it but animations are glitchy and change from one boat to another, it changes between different sprites (not the ones it was meant to). How to fix this issue?
I attached the .png file of the boat, hope that helps.
 

Attachments

CT_Bolt

Global Moderator
Staff member
Resource Team
Joined
Nov 12, 2015
Messages
566
Points
248
Website
ctbolt.wordpress.com
I downloaded an animated boat and I was planning to use it but animations are glitchy and change from one boat to another, it changes between different sprites (not the ones it was meant to). How to fix this issue?
I attached the .png file of the boat, hope that helps.
Hmm... it looks like it's not quite really an animation...
Instead various ships placed where the "stepping" frames would be for the character.

Here's a fix for you:
I've flipped the image for the 'left' direction.
!$Water-Cave-Boat.png
  • Uncheck Stepping & Walking.
  • Turn Frequency to 5 (Optional)
upload_2019-1-30_11-2-28.png
upload_2019-1-30_11-10-49.png
..That still won't give you all directions though of course as they were never made by the pixel artist.

If you don't wan't it to move at all... Check Direction Fix, Uncheck Stepping, Uncheck Walking.
If you want it to loop the ones going vertical...
Uncheck Direction Fix, Uncheck Stepping, Uncheck Walking.
Then use the following move-route:
upload_2019-1-30_11-25-5.png
...but they didn't appear to be animated to me anyway...

Let me know how it goes. (cool)(icecream)
 
Last edited:
Top